summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbd <bdunahu@operationnull.com>2025-04-12 01:36:59 -0400
committerbd <bdunahu@operationnull.com>2025-04-12 01:36:59 -0400
commitb91eb002d4e6b2dc0c51b03df57c5089659ac669 (patch)
tree3ad405efc96f439a9e7af2bcac53c808a4667ef0 /CMakeLists.txt
parent28a2788e2c59357d9269e558b0bd45db3241c42d (diff)
Add C11 test class header as base cache fixture class
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 661e45c..558f214 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ if(RAM_TESTS)
# test executable
add_executable(tests ${SRCS} ${TESTS})
- target_include_directories(tests PUBLIC ${PROJECT_SOURCE_DIR}/inc)
+ target_include_directories(tests PRIVATE ${PROJECT_SOURCE_DIR}/inc ${PROJECT_SOURCE_DIR}/inc)
target_link_libraries(tests PRIVATE Catch2::Catch2WithMain PRIVATE)
# test discovery