summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbd <bdunahu@operationnull.com>2025-03-02 13:37:53 -0500
committerbd <bdunahu@operationnull.com>2025-03-02 13:37:53 -0500
commita9af4fd3243e470ff33d50968f998bf78c152717 (patch)
treeb9815d43d79b631939cd531512b470829ba16436 /CMakeLists.txt
parenta81e74ecfc73e27cceba863b8c780ebde51a8d47 (diff)
Added logger class, tests, arg parsing and cleanup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e36b290..17ec29f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,20 +16,22 @@ include_directories(
# gather source files
file(GLOB_RECURSE SRCS "src/*.cc")
-list(REMOVE_ITEM SRCS "${CMAKE_CURRENT_SOURCE_DIR}/src/rv.cc")
+list(REMOVE_ITEM SRCS "${CMAKE_CURRENT_SOURCE_DIR}/src/main.cc")
# find python3 components
find_package(Python3 COMPONENTS Development REQUIRED)
# binary executable
-add_executable(${PROJECT_NAME} ${SRCS} src/rv.cc)
+add_executable(${PROJECT_NAME} ${SRCS} src/main.cc)
target_link_libraries(${PROJECT_NAME} PRIVATE Python3::Python)
find_package(Catch2 REQUIRED)
-set(TESTDIR tests)
+
+#gather test files
+file(GLOB_RECURSE TESTS "tests/*.cc")
# test executable
-add_executable(tests ${SRCS} ${TESTDIR}/tests.cc)
+add_executable(tests ${SRCS} ${TESTS})
target_link_libraries(tests PRIVATE Catch2::Catch2WithMain PRIVATE Python3::Python)
# test discovery