summaryrefslogtreecommitdiff
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorSiddarth Suresh <155843085+SiddarthSuresh98@users.noreply.github.com>2025-03-25 12:41:38 -0400
committerGitHub <noreply@github.com>2025-03-25 12:41:38 -0400
commit7ad79d8430ee22b0180e7077fe727153333e47f6 (patch)
tree8d2d9df8054214d4c019ace03e33f74e6ba571d0 /gui/CMakeLists.txt
parent877aa98855fad77ef93a8c9f5a5e8191fbb9e699 (diff)
parent895b5ddd6fe4db906720ecbf0de0cab5acdb35ec (diff)
Merge pull request #33 from bdunahu/dev-sid
Initial GUI Commit
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
new file mode 100644
index 0000000..6b5eb22
--- /dev/null
+++ b/gui/CMakeLists.txt
@@ -0,0 +1,30 @@
+cmake_minimum_required(VERSION 3.5)
+set(CMAKE_CXX_COMPILER "g++")
+
+add_compile_options(-Wall -lstdc++)
+add_compile_options(-Wextra -Wpedantic)
+
+# cpp standard
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+# find QT components
+find_package(Qt6 COMPONENTS Widgets REQUIRED)
+qt_standard_project_setup()
+
+file(GLOB SRCS
+ "*.h"
+ "*.cc"
+ "*.ui"
+)
+
+# gather gui source files
+qt_add_resources(GUI_RESOURCES "resources.qrc")
+
+add_executable(risc_vector ${SRCS} ${GUI_RESOURCES})
+target_link_libraries(${PROJECT_NAME} PRIVATE ${PROJECT_NAME}_lib Qt6::Widgets)
+
+set_target_properties(risc_vector PROPERTIES
+ RUNTIME_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}"
+)
+