summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbd <bdunahu@operationnull.com>2025-04-11 20:52:19 -0400
committerbd <bdunahu@operationnull.com>2025-04-11 20:52:19 -0400
commit7a63a61ac7d4a3e4a6667055ea55db1c55779a23 (patch)
tree7bd6ca943e97737d68a03fab900b0f7f18079e1e /CMakeLists.txt
parent4181123e760abb9e6f4e753925f4aa24cf0eea85 (diff)
Modify README and CMakeLists from repository split
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9daac12..f8ec7be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.5)
set(CMAKE_CXX_COMPILER "g++")
-project(risc_vector)
+project(ram)
set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
@@ -16,16 +16,9 @@ include_directories(
${PROJECT_SOURCE_DIR}/inc
)
-# add gui
-add_subdirectory(gui)
-
# gather source files
file(GLOB_RECURSE SRCS "src/*.cc")
-# find QT components
-find_package(Qt6 COMPONENTS Widgets REQUIRED)
-qt_standard_project_setup()
-
# binary executable
add_library(${PROJECT_NAME}_lib ${SRCS})
target_link_libraries(${PROJECT_NAME}_lib)