summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9daac12..f8ec7be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.5)
set(CMAKE_CXX_COMPILER "g++")
-project(risc_vector)
+project(ram)
set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
@@ -16,16 +16,9 @@ include_directories(
${PROJECT_SOURCE_DIR}/inc
)
-# add gui
-add_subdirectory(gui)
-
# gather source files
file(GLOB_RECURSE SRCS "src/*.cc")
-# find QT components
-find_package(Qt6 COMPONENTS Widgets REQUIRED)
-qt_standard_project_setup()
-
# binary executable
add_library(${PROJECT_NAME}_lib ${SRCS})
target_link_libraries(${PROJECT_NAME}_lib)