summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbd <bdunahu@operationnull.com>2025-02-24 19:44:00 -0500
committerbd <bdunahu@operationnull.com>2025-02-24 19:44:00 -0500
commit9028b78a0d668a8893d4e5ce65fa1d332be35cfa (patch)
treed7c2716391e501dfcb2834463771a7a1c1968c91 /CMakeLists.txt
parent42c03e2ad6110625b54c8aab5960a5d3723e54b0 (diff)
Configure CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..505517f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.11)
+project(risc_vector)
+
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_COMPILER "g++")
+set(SRCDIR src)
+set(PYTHON_VERSION 3.10)
+
+find_package(Python3 COMPONENTS Development REQUIRED)
+
+add_executable(${PROJECT_NAME} ${SRCDIR}/rv.cc)
+
+target_link_libraries(${PROJECT_NAME} Python3::Python)