summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..505517f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.11)
+project(risc_vector)
+
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_COMPILER "g++")
+set(SRCDIR src)
+set(PYTHON_VERSION 3.10)
+
+find_package(Python3 COMPONENTS Development REQUIRED)
+
+add_executable(${PROJECT_NAME} ${SRCDIR}/rv.cc)
+
+target_link_libraries(${PROJECT_NAME} Python3::Python)